Chat with us, powered by LiveChat

Support:

0800 007 3060


Sales:

0800 007 3050


Main:

0800 007 3040

Apple release macOS 10.15 Catalina – Monday 7th October.

Its new features such as music, TV and Podcasts apps to replace iTunes, Photos, Reminders, and Notes all get major upgrades and Sidecar lets you use an iPad as a second screen or graphics tablet with an Apple Pencil – cool stuff!

But, upgrading your business workstations right away is likely to cause you problems.  So what should you do?

Don't upgrade to Catalina without seeking advice!+

We understand you’re keen to have the latest and greatest and make use of your iPad but Catalina, more than previous major macOS upgrades is not something you should install right away. The reason is that Apple changed Catalina in fundamental ways that could break your essential apps or workflows.

Why should we delay and plan our upgrade?+

32-bit apps don’t run anymore: Macs have had 64-bit processors since 2006, macOS has been gaining 64-bit support since 10.6 Snow Leopard and Apple has been warning developers for years that old 32-bit apps would stop being supported at some point. With Catalina, that time has come.

To identify which 32-bit apps and services won’t work in Catalina, you can download and run the free Go64 utility from St. Clair Software.

Catalina runs in its own read-only volume: To increase security and ensure an attacker can’t subvert macOS itself Apple changed the disk structures under Catalina.  Now, instead of having one main volume that contains both macOS and your apps and documents, Catalina runs in its own read-only volume.  Apple have made the Catalina boot volume and the main volume look like a single volume but this may cause scripts that access files stored in newly changed parts of the directory hierarchy to break.  This could mean that backup apps such as Carbon Copy Cloner will need to be updated to be able to backup and restore data properly. Never upgrade without a backup or before your backup app is 100% compatible!

Newly installed apps must be notarized by Apple: Notarization is an automated process that Apple uses to verify that an app distributed outside the Mac App Store is free of malware. It’s not an option.  In a statement, Apple said, “Mac software distributed outside the Mac App Store must be notarized by Apple in order to run on macOS Catalina.” However, Apple have also said that notarization requirements don’t apply to previously distributed software.  It’s likely that older apps already on your Mac when you upgrade it will continue to work fine but if you try to install an older, unnotarized app on a Mac running Catalina that may not work.

Apps require more permissions than before: In the last few versions of macOS you’ve probably seen apps asking for permission to do things like access data in Contacts, Calendars, Reminders, and Photos, or be able to use the camera or microphone.  In Catalina, apps will have to ask for permission to access files in your Desktop and Documents folders, iCloud Drive, and external volumes.  Plus, you’ll be prompted before any app can capture keyboard activity or a screenshot or screen recording.  That’s good for security but it’s possible that older software won’t know how to ask or won’t work properly if you deny its request.

Kernel extension installs require restarts: Kernel extensions are often necessary for third-party hardware peripherals or for apps that need particularly low-level access to the operating system.  Installing one requires giving it permission in System Preferences > Security & Privacy > General even now in Mojave and in Catalina you’ll also have to restart your Mac.  We wouldn’t be surprised if problems arise from these new security requirements coupled with the read-only boot volume forcing kernel extensions to run from a new location.

Unanticipated backward-compatibility issues: Here’s the scenario. You upgrade to Catalina which requires an update to an app you rely on.  The new version of this app requires a new file format for its documents and older versions can’t read it.  But since you can’t upgrade all the Macs in your office because some still require 32-bit apps you end up in a situation where you can’t easily share or collaborate these documents within the office anymore.  Call us cautious but we’ve seen this sort of thing happen before.

When should we update?+

Historically, we’ve given general the general advice of waiting until the .1 or .2 update of macOS before you even consider upgrading.  However, with all the trouble Apple has had this year with it’s iOS and all the potential problems Catalina’s changes could cause we strongly suggest waiting for the 10.15.3 or 10.15.4 to update.  As a precaution, all the mac workstation we support as part of our Business-PRO support plan have been blocked from running this update.

However, if you’re still keen to upgrade we recommend you get in touch to discuss the best way forward.

Share Via: